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Introduction
Garibaldi Pro software provides technicians and commissioning agents with features and tools
to easily configure wireless devices and manage any Echoflex installation from one simple
project browser view. You can commission a new project from scratch using the embedded
configuration logic or connect to an installed project.
For an installed project, you can identify all Echoflex devices in the system, monitor wireless
traffic, evaluate performance, troubleshoot, and revise configuration settings as required.
This guide describes how to use Garibaldi Pro to organize and configure wireless devices that
make up your energy efficient lighting system.

Features
•
•
•
•
•
•
•
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Create scalable wireless control projects, remotely or on site
Online access to database of Echoflex devices
Intuitive file representation of real project sites
Tools to set up and manage project structure and configurations
Identify and include pre-configured controllers
Share project configuration files
Choice of user preferences
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Document Conventions
Echoflex user documentation is designed for print or electronic use. Cross-references
highlighted in this document are links to the referenced section of the guide.
This guide uses the following conventions:
•
•
•

Names of configuration settings are emphasized in italics.
Switch actions (ON/OFF) and relay events (lights ON/OFF) are emphasized in ALL CAPS.
Interactive elements of the interface for a task are emphasized in Bold.

Please email comments about this guide to: TechComm@etcconnect.com.

Note: Notes contain information that is supplemental to the main text.

Tip: Tips suggest time-saving methods to improve your workflow.
CAUTION: A Caution statement indicates situations where there may be
undefined or unwanted consequences of an action, potential for data loss or
an equipment problem.

Help from Technical Services
If you are having difficulties that are not addressed by this document, contact Echoflex support
at service@echoflexsolutions.com or the main website at echoflexsolutions.com. If none of
these resources are sufficient, contact Technical Services directly at the office identified below.
When calling for help, take these steps first:
•

Prepare a detailed description of the problem

•

Be near the equipment for troubleshooting

•

Find your notification number if you have called in previously

Technical Services Department
3031 Pleasant View Road
Middleton, WI 53562
800-775-4382 (USA, toll-free)
+1-608-831-4116
service@echoflexsolutions.com

Introduction
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Getting Started
This section describes the system requirements for installing Garibaldi Pro and how to get upand-running fast.
Once your system is set, explore Best Practices for recommendations on how to use Garibaldi
Pro effectively to manage wireless project configurations.

System Requirements
•
•
•
•
•

•
•

Computer with Windows ® 10
2 GHz processor, or better
1 GB RAM, or better
70 MB free disk space
Echoflex Serial Interface
- Model ERUSB-SU, 902 MHz, part number: 8188A1142
- Model ERUSB-SY, 868 MHz, part number: 8188A1343
Display resolution of 1024 x 768, or better
Internet connection

Install Software
Garibaldi Pro is available for download from Echoflex at echoflexsolutions.com at no cost.
1. Download the Garibaldi Pro executable file, example project file, and PDF version of the
user guide, if required. An online version of the guide is included with the software.
2. Run the installation wizard.
3. Launch Garibaldi Pro.
4. Click Tools > Update Database from the Main Menu to generate the latest version of the
Echoflex device database.

Welcome Screen
The Welcome Screen displays real-time graphic feedback of detected messages and signal
strength to help you evaluate performance and troubleshoot communication issues.

Buttons at the bottom of the Welcome Screen provide three options to get started:
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•
•
•

New Project Quick Start - select to create an automated structure for a new project.
New Blank Project - select to create the project structure manually.
Open Project - to get oriented with the interface, open an existing Garibaldi Pro file or the
example project file from the folder you selected for the download. Explore the structure
and elements as described in Home Screen.

To generate the latest version of the Echoflex device database, click Tools > Update Database
from the Main Menu.

Best Practices
Garibaldi Pro is designed to save time and enhance system control. The following best
practices are provided to help you get the most out of this tool.
•

•

•
•
•
•

•

Before you start a Garibaldi Pro project, gather all available information about the
installation plan, the devices, and radio IDs as this will simplify the project management
process. See Garibaldi Project Files on page 8.
Use the Upload and Download synchronizing features knowingly. For example, use these
features only when you are confident in the device information (download) or the
Garibaldi Pro project file information (upload). The information on the destination is
overwritten. See Upload Links and Settings on page 16 and Download Links on page 19.
Save the project file each time you complete a configuration for a space.
When adding devices to the Project Browser, enter the radio IDs to enable real linking and
take advantage of the Download Links feature.
Use Copy a Space to quickly build a structure that uses the same configured devices
throughout the project site.
Add descriptive Device Labels to provide more information about connections in the
project. Adding a unique label that identifies relationships may help in projects that have
many of the same type of device on the same floor.
Use a naming convention that works if you copy the space. For example, if your zone
names are Rm100 daylight and Rm100 non-daylight, it may be confusing if you copy the
space to Room 405. Avoid using space-specific identifiers, or be prepared to rename them.

Getting Started

4

Home Screen
The Home Screen displays the Main Menu, the interactive Project Browser on the left, and the
context-sensitive Configuration Panel on the right.
At the bottom of the screen, a green icon indicates a connected serial interface that enables
wireless communication with devices that are within range. A red icon displays when a serial
interface is not connected.

Main Menu
You can access the following basic control features from the Main Menu.
File - Create new projects or manage existing projects using the file options. Garibaldi Pro
projects have a .gpf file extension.
View - Set your user preferences: select a Device Settings level and choose between a Dark
Theme or Light Theme to display the interface.
Tools - Update the Echoflex device type database for use in your projects. Requires an internet
connection.
Help - Access the online help.
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Project Browser
The Project Browser provides an expandable project structure that identifies the project's site,
buildings, floors, and spaces where you can coordinate, connect, and configure devices. A
space describes any type of defined area, for example a room, hallway, stairwell, or parking
garage. The Project Browser also identifies zones and control points, the location of each
device, and whether it is linked.
Each element in the Project Browser has a right-click menu that provides context-sensitive
control options. To edit Project Browser elements, see Manage Project Browser Elements on
page 11.
A Garibaldi Pro project is a virtual representation of a site that becomes a working model only
after the controllers are powered and configured with radio IDs for all the linked devices.

Tip: To expand or collapse a level in the Project Browser click the black triangle.
Double-click the name of the element to expand or collapse all levels.

Configuration Panel
The tabs that display in the Configuration Panel are determined by the element selected in the
Project Browser. The descriptions below provide an overview of each tab. For working
instructions, see Develop a Project.

Project Device Types
The Project Device Types tab lists the device types that have been selected from the database
and can be added to your project. Each device type listed has a model, firmware version, and
short description. To edit the list of devices, see Manage Project Device Types on page 10.
About the Device Database: The device database includes profile information for all the
eligible Echoflex devices and firmware versions, both current and previous. Every project must
have a Project Device Types list. Creating a Project Device Types list simplifies placing multiple
instances of the same device throughout the project.
When you create a new list make sure you select from an up-to-date database. Click Tools >
Update Database from the Main Menu to generate the latest version.

Home Screen
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Discovered Controllers
The Discovered Controllers tab lists controllers that are powered and within wireless range of
the Echoflex serial interface. This feature provides a quick method for identifying controllers
when you are at an installed project site. When a discovered controller is added to the Project
Browser, the controller's profile is automatically added to the Project Device Types list. To use
this feature, see Manage Project Device Types on page 10.

Device Info
The Device Info tab provides profile information about the device that is selected in the Project
Browser: an image, description, label, and unique radio ID. If the radio ID is not entered, you
can choose a method for adding it. To edit the device label or radio ID, see Edit Device
Information on page 13.

Settings
The Settings tab provides a list of settings for a configurable device that is selected in the
Project Browser. Settings are organized into levels and sorted alphabetically according to the
control function. To configure settings, see Configure Device Settings on page 15.

Device Links
The Device Links tab provides a structured view of the devices that are linked or can be linked
to the device that is selected in the Project Browser. To link a device, see Link a Device on
page 11.

Control Points
The Control Points tab provides a structured view of the eligible controllers that can be
associated to the zone that is selected in the Project Browser. A control point in a zone
describes a specific wiring connection, like a circuit number. You can create and label control
points to map the wiring connections for a project. A zone can have multiple control points,
each of which can be associated with a different controller. To associate a control point, see
Associate a Control Point on page 12.
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Garibaldi Project Files
Garibaldi Pro is a software tool that allows you to manage wireless Echoflex projects easily and
efficiently. It provides a representation of the devices' physical locations, their relationships,
settings, and control. Garibaldi Pro also allows you to define and modify these elements and
synchronize the site installation with the Garibaldi Pro project file.
•

If your project was pre-commissioned by Echoflex with a ship date of September 2021 or
later, a Garibaldi Pro project file already exists. Use the QR code provided with the project
shipment to access the file in the project folder. If you cannot access the code, contact the
sales agent or Echoflex and request the file.

•

If your project was pre-commissioned by Echoflex before September 2021, the project file
is not compatible with Garibaldi Pro. You may use the file with the previous version of
Garibaldi software to manage your project and make changes as necessary. If the file is not
available, contact the sales agent or Echoflex to request this file.

Note: To update and manage an old project with Garibaldi Pro, use the new project
tools to recreate it in Garibaldi Pro.
•

If you have an installed project that was not pre-commissioned by Echoflex, the process of
creating the Garibaldi Pro project file will be more hands-on. Echoflex products are
shipped with extra radio ID labels for applying to the As-Built Drawings for the project. Use
these drawings and radio ID labels to map your project site structure, identify, and locate
installed devices. Garibaldi Pro provides features to help you easily create links between
devices and download from configured controllers.

Once you are up and running, managing different aspects of an Echoflex project becomes
straightforward. For example, replacing a controller on site is easy when you can identify its
exact location, the firmware version, and what is linked to it. After you install the replacement,
you can simply Upload Links and Settings to fully integrate the new controller.

Create a New Project
Garibaldi Pro provides multiple ways to start a new project.
•
•
•

New Project Quick Start - an easy-to-use default template that prompts you with steps to
build a project structure.
New Blank Project - a manual way to design a project structure.
Open Project - open an existing project file to use as a template and click File > Save As.

Note: You can create the project structure, add and link devices, and configure
settings without being on site. To record the unique radio ID you must either have the
information to enter manually or capture it wirelessly on site. See Enter a Radio ID on
page 14.

New Project Quick Start
The New Project Quick Start method makes it easy to define a structure using terminology that
best describes your project and to select devices you want to include.
1. Click File > New Project Quick Start and follow the prompts.
2. Double-click or drag and drop devices from the database to the Project Device Types list. To
remove a device you added in error, double-click or drag it back from left to right.

Garibaldi Project Files

8

3. Click Finished. The structure you created is displayed in the Project Browser. The following
screenshot shows the default element names.

4. Use the right-click menu to rename, add, or delete an element.
5. Drag and drop devices from the Project Device Types list to the target space in the Project
Browser. See Place a Device.

New Blank Project
Once you are familiar with Garibaldi Pro and know the project structure you want to create, it
may be more efficient to create a new project manually.

Note: To use an existing project as a template for a new project, open the template
project, click Save As, and modify the elements as required.

Create a Project Structure
Use the right-click menu in the Project Browser to rename, add, or delete elements as
required.
1.
2.
3.
4.

Click File > New Blank Project.
Right-click New Project Site and click Rename Site to name the project.
Right-click the renamed project site and click Add Building.
Enter a name for the building and click OK. A hierarchical sub-structure that includes one
floor, one space, one zone, one control point, and a place for devices is automatically
created. Add multiple buildings as required (for example, West Wing and East Wing).

Create a Project Device Types List
A new blank project does not have any device types. Select the devices you want for the
project from the Echoflex device database.
1. Click Devices in the Project Browser and click the Project Device Types tab in the
configuration panel.
2. Click Manage to access the device database.
3. Select the Only Display C urrent Device Types check box to restrict the list of devices. If you
are looking for older devices or want to see all the devices, clear the check box.

Note: To find a device, use the Search field to enter a model name or other criteria.
Select a device to display its profile information.
4. Double-click or drag and drop each device from Device Database, one at a time, right to
left. To remove a device you added in error, double-click or drag it back from left to right.
5. Click OK to save the Project Device Types list and close the window. To place an instance
of a device in a space, see Place a Device on page 11.
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Develop a Project
Garibaldi Pro's management features make it easy to develop and edit a project file. You can
modify the device list, place devices in spaces according to your design, edit and copy the
project structure, establish links, and configure settings.

Manage Project Device Types
Each project has a Project Device Types list that you can edit at any time. To ensure you have
access to the latest device catalog, update the device database (Tools > Update Database).
Profile information for device types is generic; the radio ID field is blank and all the settings are
default values. This allows you to place an instance of a device in the Project Browser once or
multiple time, and then modify it as required.
1. Select any element in the Project Browser and click the Project Device Type tab.
2. Click Manage to access the device database.

3. Select the check box Only Display C urrent Device Types to restrict the list of devices. To
display all the device versions, past and present, clear the check box.

Note: To find a device, enter the model or other criteria in the Search field. Select a
device to view its image and brief description.
4. Add devices to the Project Device Types list from the database. Double-click or drag and
drop each device from Device Database, one at a time, right to left. To remove a device,
double-click or drag and drop it from left to right.
5. Click OK to save the Project Device Types list and close the window. To place an instance
of a device in a space, see Place a Device on the next page.

Tip: To reuse a Project Device Type list for another project, create a new project
using Save As and modify elements as required.

Develop a Project
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Place a Device
After a device is added to the Project Device Types list, you can place an instance of it in a
space, or in multiple spaces in the Project Browser. An instance of a device type from the
Project Device Types list always has default settings.
1. Expand the Project Browser to display the target space.
2. Select the device from the Project Device Types tab, and then drag and drop it to the
space. If not already open, the Devices folder expands to display the device that has been
added, sorted alphabetically.
• To link the device, see Link a Device below.
• To configure the device, see Configure Device Settings on page 15.
• To delete the device if it was added in error, right-click and select Delete.

Manage Project Browser Elements
To make navigation easy, elements in the Project Browser are displayed alphabetically.
•
•

•
•

Use the context-sensitive right-click menu to rename or manage elements.
Expand and collapse the project structure to manage the view of large projects that have
multiple buildings, floors, and spaces. To add an instance of a device, see Place a Device
above.
Use drag-and-drop to reorganize devices (for example, to move a device to a different
space or floor).
Use Copy a Space to quickly replicate the layout of a space that is the same on other floors
or buildings.

Tip: To select a device in the Project Browser using its unique radio ID, right-click the
name of the Site and select Find Device in Project Browser or press CTRL-F on your
keyboard.

Link a Device
In an Echoflex solution, links are the connections that establish wireless communication
between devices. Controllers have a link table that is used to manage the devices it recognizes
by radio ID and equipment profile. Each controller can support up to 20 devices.
Every device in the Project Browser has a link icon and control function, and multi-channel
devices have a control function for each channel. The link icons and control functions are
displayed when you click to expand a device. Select the control function to display the devices
that are linked. If no device is linked, the Device Links tab displays eligible links in the space
(for example, switches or sensors for a controller, or controller channels for a switch or
sensor).
If you are mapping an installed project, you can download the existing links from discovered
controllers. See Download Links on page 19.

Note: To create a link to a device in another space or on another floor, navigate the
structure in the Device Links tab.
You can link devices even if their radio IDs have not been entered yet. When the radio IDs are
recorded in the Device Info tab, link information can be uploaded from Garibaldi Pro to the
target controller. See Upload Links and Settings on page 16.
1. Select a device in the Project Browser and expand it to show its link icon and control
function.
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2. Select the control function.
• If it is linked, ( ) the Device Links tab displays the linked devices.
• If it is not linked, ( ) the Device Links tab displays eligible devices on the same floor.
3. Drag and drop the link icon in Device Links tab onto the link icon of the target device
displayed in the Project Browser. The link icon updates to indicate the devices are now
linked. To remove the link, right-click the link icon in the Device Links tab and select
Remove Link.

Note: If you move a device to another space, it maintains all the information you
have assigned to it: links, radio ID, and settings.

Send a Learn Command
If a controller is not easily accessible, you can activate Learn mode from Garibaldi Pro to link a
device you can access. It works the same way as physically pushing the Learn button on the
controller. The Power LED on the controller blinks to indicate that it is in Learn mode.
If the controller has multiple channels, sending another Learn command activates the next
channel on the controller. For example, to activate the third channel on an ELED3, you must
send three Learn commands.
To exit Learn mode on a single channel controller before it times out, send another Learn
command. To exit Learn mode on a multi-channel controller, send one more Learn command
than there are channels. Learn mode times out in 60 seconds.

Note: When a single channel controller is in Learn mode, the relay toggles the
connected load ON and OFF. For multi-channel controllers, the activated channel
reflects the dimming level for the connected load. If visible, the color of the LED also
indicates the activated channel: red = CH1, green = CH2, and blue = CH3.
To send a command to a controller, you must be within wireless range of the powered device.
1. Select the controller in the Project Browser.
2. Select Send Learn C ommand from the right-click menu. To confirm the command, the
Learn LED on the controller is lit.
3. Send a teach message from the device you want to link to the controller:
a. For a sensor, press the Teach button on the sensor.
b. For a switch, active the ON switch three times quickly.

Note: If you create a link using this method, the link is not automatically recorded in
the project. You must Download Links to synchronize the project file with the links on
the controller.

Associate a Control Point
For complex projects you may want to use the zones and control points feature. This added
level of project design lets you associate controller functions with custom zones and control
points (wiring connections) that you identify in a space. For example, a classroom may have
two lighting zones: a whiteboard zone and a general lighting zone. The general lighting zone
may have two control points; one for daylight-controlled fixtures and one for non-daylight
controlled fixtures.
1. Select the control point in a Zone. The controller's eligible functions (channels) display in
the Control Points tab in the configuration panel. If the control point is not associated with
a function, the icon is orange ( ). If the control point is associated, the icon is green ( ).

Develop a Project

12

2. Drag and drop the controller function to the control point in the Project Browser, right to
left. The icons for both elements change from orange to green to confirm the association.

To remove an association, either right-click the control point and select Remove Association
to C hannel or right-click the channel and select Remove Association to C ontrol Point. A
controller's control point associations are managed separately from the devices that are linked
to it. See Link a Device on page 11.

Note: To help track the associations that you create, the name of the controller’s
function is appended to display the space, zone, and control point.

Edit Device Information
Device Info includes the profile information from the database and two editable fields: Device
Label and Radio ID.

Enter a Device Label
You can add a label to any device in the Project Browser. The Device Label helps identify a
device when there are multiple instances of the same device in different buildings, floors, or
spaces. If you use Copy a Space, all Device Labels in the space are included in the copy.
1. Select the device in the Project Browser and click Device Info in the configuration panel.
2. Enter a name in the Device Label field. The label appears in brackets to the right of the
device name in the Project Browser.
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Tip: Add descriptive Device Labels to provide more information about connections in
the project. Adding a unique label that identifies relationships may help in projects
that have many of the same type of device on the same floor.

Enter a Radio ID
To make a working wireless connection you need to identify the unique radio ID for each
device. You can find the radio ID printed on the device label or you can capture it wirelessly
when you are within range. Information between Garibaldi Pro and the devices cannot be
shared until the radio IDs are entered.
1. Select the device in the Project Browser and click Device Info in the configuration panel.
2. Choose a method to set the radio ID:
a. Click Manual Entry and enter the radio ID in the field. Click Apply.

b. If you are on site and within wireless range, you have more options:
• For sensors and stations, click Teach Button > Begin to enable reception, and then go
to the device and press the Teach button to send a message that contains its radio ID.

•

For switches, click Switch Press > Begin to enable reception, and then go to the
switch and press the ON button three times quickly to send a message that contains
its radio ID.

•

For controllers, click Discovered C ontrollers > Begin to identify the radio ID of a
target controller.

3. The device’s unique radio ID is recorded and displays at the top of the Device Info tab.

Note: If you are mapping devices on an installed project site, you can use Download
Links from discovered controllers to help identify the radio IDs of linked devices.

Develop a Project
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Configure Device Settings
Echoflex devices are designed to suit a wide range of installation applications. To create a
target effect, you may have to modify the default settings.
Configurable devices have two kinds of settings: those that manage the device and those that
manage each output (channel). Settings are organized alphabetically within these groupings.

Note: Configuration settings that control the operation of sensors, like occupancy
timers, are saved on the linked controllers.
1. Select the device in the Project Browser and click Settings in the configuration panel.

Tip: Use Search to isolate a type of setting (for example, all the Fade or Timer
controls).
2. Select a setting to display its description and the parameters. Depending on the type of
setting, you can use a proposed value, enter a value, or make a selection. The names of
settings that have been modified display in bold typeface in the Settings tab.
3. Modify the setting as required and click Apply. Repeat for all the settings you want to
configure. The configuration is saved in the project file but is not yet transferred to the
device. See Upload Links and Settings on the facing page for more information.
To restore default settings for a device, use the device’s right-click menu in the Project
Browser. You cannot undo this command; make sure you want to restore all default settings.

Note: If the Settings you want to modify are not displayed, increase the selected
user level from the Main Menu (for example, View > Advanced Device Settings).

15
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Copy a Space
Office buildings and hotels often use the same lighting configuration for multiple spaces
throughout a project site. The Copy Space feature can save a lot of time and ensure accurate
repetition when you build your Garibaldi Pro project file.
Use Copy Space to copy zones, control points, devices, and links and settings—everything
defined in the space except device radio IDs.
If the space has connections to another space:
•
•

Links to devices in another space are also copied. Use the Device Links tab to view links.
An association to a control point in another space is not copied. For example, if the lights
in the corridor space are controlled by a switch at the reception desk, that association is
not copied. Use the Control Points tab to view associations.

You can paste a space multiple times, on any floor of any building. The pasted space name is
appended with an incrementing number. For example a pasted copy of Room 100 appears as
Room 100(1). If you paste again on the same floor without renaming the first paste, the space
name will be Room 100(2).
1.
2.
3.
4.

Select the space you want to copy in the Project Browser.
Select C opy Space from the right-click menu.
Click the floor in the building where you want to paste the space.
Select Paste Space from the right-click menu. The space is pasted and named with a
number to identify it as a copy.
5. Rename the copied space and enter the unique radio IDs for each of the devices.

Tip: Use a naming convention that works if you copy the space. For example, if your
zone names are Rm100 daylight and Rm100 non-daylight, it may be confusing when
you copy the space to Room 405. Avoid using space-specific identifiers.

Upload Links and Settings
After you define the links and configure the settings for a device in a project, you can copy the
information to the installed device. Unlike the download features (Download Links and
Download Settings), the upload feature includes both the device links you created and the
settings you configured. The whole configuration is transferred to the device in one
transaction.
To upload links and configured settings to a device, you must have a connected Echoflex Serial
Interface and be within wireless range of the powered device.

CAUTION: Make sure you want to overwrite the device’s configuration
(links and settings). You cannot undo this command.
1. Select the device in the Project Browser.
2. Select Upload Links and Settings from the right-click menu. To confirm the transfer, the
device will blink its connected load.

Develop a Project
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Restore Default Settings
It is easy to track the settings that have been customized in Garibaldi Pro. The names of
settings that have been modified display in bold typeface in the Settings tab.

To restore the default settings in the Garibaldi Pro project file and on the controller, the
controller must be within wireless range.

CAUTION: Make sure you want to restore the default settings for the
selected device. You cannot undo this command.
1. Select Restore Default Settings from the right-click menu of the device and click OK to
confirm. The default settings in the project file are restored.
2. Select Upload Links and Settings from the right-click menu of the device and click OK to
confirm. The default settings on the controller are synchronized with the project file.

17
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Work with Installed Devices
Garibaldi Pro's connectivity features make it easy to capture information from an installed site
and copy it into a Garibaldi Pro project. At an existing project site, you can move systematically
through the building to discover devices and locate them in the Project Browser you created.
You can also retrieve the links and the settings to capture the existing installation.

Discover Controllers
If you are working on an installed project site, you may find it more convenient to add the
installed controllers to the Project Browser using their wireless signal. You must have a
connected Echoflex Serial Interface and be within wireless range to use this feature.
1. Select an element in the Project Browser and click the Discovered C ontrollers tab in the
Configuration Panel.
2. Click Find/Refresh to generate a list of controllers within range. The controllers that are
discovered are color-coded and listed in order of their signal strength to help you identify
their proximity.

Green text = good signal strength
Yellow text = fair signal strength
• Red text = poor signal strength
3. If there is more than one controller, select a controller and click Identify to make the
connected load blink.
•
•

Note: If another brand of controller is discovered it will display in the list, but you
cannot place it in a Garibaldi Pro project.
4. Drag and drop the selected controller to a space in the Project Browser. The discovered
controller is listed in the Project Device Types list with its unique radio ID. To retrieve the
controller’s current configuration settings, see Download Settings on the next page.
After a discovered controller is placed in the Project Browser, it is no longer available in the
Discovered C ontroller tab. Unlike an instance of a device profile, a discovered controller is an
installed device, not virtual, and can only be discovered and placed once.
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Download Links
When you add a discovered controller to your project, you may also want to retrieve its
configured links to other devices in the project. The controller's link table identifies the radio
IDs and Equipment Profiles of the devices that are linked to the controller, not the type of
device. Use Download Links to update the Garibaldi Pro project file with information on the
controller. Linked devices in the Project Browser that do not have radio IDs are not affected.

CAUTION: If the controller in the Project Browser has links to devices that
have radio IDs, the links will be overwritten with the controller's link table
you download. Make sure you want to overwrite the links in the project file
with the links on the controller. You cannot undo this command.
To download links from a device, you must have a connected Echoflex Serial Interface and be
within wireless range of the powered device. A controller can have up to 20 linked devices.
1. Select the device in the Project Browser.
2. Select Download Links from the right-click menu.
Garibaldi Pro sends a query to the target controller and retrieves its table of linked radio
IDs. The devices identified by their radio IDs now display as being linked (
) to the
controller in the project.
If a radio ID discovered in the controller's link table does not match any of the radio IDs of
devices in the Project Browser, you can try to find the device using the Equipment Profile or
the radio ID that display in the dialog box. Devices can also be linked manually. See Link a
Device on page 11.

Download Settings
You can retrieve the configured device settings for projects that have existing installed devices.
For example, you can download settings from controllers that you add to a project using
Discover Controllers.
To download configured settings from a controller, you must have a connected Echoflex Serial
Interface and be within wireless range of the powered device.
1. Select the device in the Project Browser.
2. Select Download Settings from the right-click menu.
The names of settings that have been modified display in bold typeface in the Settings tab. To
restore default settings, select Restore Default Settings from the right-click menu.
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FAQ
How do I find a radio ID?
Select the device from the Project Browser and then open the Device Info tab in the
configuration panel. See Enter a Radio ID on page 14.

How can I relate my project file to a floor plan?
Create a Project Browser structure and rename the elements to match the floor plan's
terminology. The default names are: Site Name, Main Building, Floor 1, Space 1, Zone 1, and
Control Point a.

How do I change the switch that the controller is linked to?
Expand the controller in the Project Browser and select its control function. From the Device
Links tab in the configuration panel, right-click the current link and select Remove Link. Next,
drag and drop the switch you want to link to the controller. See Link a Device on page 11.

How do I restore the default configuration settings for a controller?
When you send a new configuration to a controller, the existing settings are overwritten. To
restore the defaults settings, use the right-click menu to restore the defaults and then upload
the settings to the controller. See Restore Default Settings on page 17.

How do I share my Garibaldi Pro project file?
There are no restrictions for sharing Garibaldi Pro project files. To open a .gps file, a user must
have an installed version of Garibaldi Pro and access to the .gps file.

Where did the device type I added in my project go?
All the devices that have been added to a space in a floor appear alphabetically in the Devices
folder. When you drop a new device in a space, it is added alphabetically using the model
name.

I cannot use Discovered Controllers. Nothing happens.
To use Discovered Controllers, you must have a connected Echoflex serial interface and be
within wireless signal range. Make sure the controllers in the space are powered.

How do I identify a target controller when there are five in the same room?
You can identify a controller whether its in the Project Browser or in the Discovered
Controllers tab. The controller you select will blink its lighting load to confirm its identity. See
Manage Project Browser Elements on page 11 and Discover Controllers on page 18.

Why can’t I configure the controller?
The device must be placed in the Project Browser before you can access the Settings tab. See
Configure Device Settings on page 15.

I modified the configuration settings for a controller, but the lighting effects were not
present when I tested the system.
A new configuration must be sent to the device for the settings to take effect. See Upload
Links and Settings on page 16.

I modified all the configuration settings I wanted to change but they vanished when I
went back to review them. What went wrong?
You must click Apply after each setting you modify to save it.

FAQ
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I made all the links and control point associations in my project, but the system
doesn’t work when I test it.
To test the lighting effects, the correct radio IDs must be set for each device. See Edit Device
Information on page 13.

How do I contact Technical Support?
If you need help with technical issues, contact service@echoflexsolutions.com.

Can I open multiple project files?
You cannot open multiple files, but you can open multiple instances of the software.

My site has two buildings with the same setup. Can I build the project structure and
device configuration for one building and then copy it?
You cannot copy a building, but you can copy a space to another building. Use Copy a Space
to replicate the spaces on the floors of one building to the floors of the second building.
Depending on the project, a better solution might be to use Save As and create a separate
project for the second building.
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